Учебник РНР
Назад Вперёд

version_compare

(PHP 4 >= 4.1.0)

version_compare - сравнивает две "PHP-стандартизованные" строки с номером версии.

Описание

int version_compare (string version1, string version2 [, string operator])

Используется, если вы хотите писать программы, работающие только в некоторых версиях PHP.

version_compare() возвращает -1, если первая версия меньше, чем вторая, 0 - если равны и +1, если вторая меньше.

Если вы специфицируете третий необязательный аргумент operator, вы можете тестировать на определённое соотношение. Возможны операции: <, lt, <=, le, >, gt, >=, ge, ==, =, eq, !=, <>, ne соответственно. При использовании этого аргумента функция возвращает 1, если это одно из соотношений, специфицированных операцией, иначе 0.

Пример 1. version_compare()
// печатает -1
echo version_compare("4.0.4", "4.0.6");

// эти все печатают 1
echo version_compare("4.0.4", "4.0.6", "<");
echo version_compare("4.0.6", "4.0.6", "eq");

Назад Оглавление Вперёд
set_time_limit Вверхzend_logo_guid


Наш баннер
Вы можете установить наш баннер на своем сайте или блоге, скопировав этот код:
RSS новости