Учебник РНР
НазадГлава 2. Инсталяция Вперёд

Серверы Caudium

PHP 4 может быть построен как Pike-модуль для Caudium web-сервера. Заметьте, что это не поддерживается в PHP 3. Следуйте простым инструкциям по установке PHP 4 для Caudium:

Пример 2-6. Инструкции по установке в Caudium
1.  Убедитесь, что Caudium установлен, до начала установки
    PHP 4. Чтобы PHP 4 работал корректно, вам понадобится Pike
    7.0.268 или новее. Для целей данного примеры мы примем, что
    Caudium установлен в каталоге /opt/caudium/server/.
2.  Измените директорию на php-x.y.z (где x.y.z это номер версии).
3.  ./configure --with-caudium=/opt/caudium/server
4.  make
5.  make install
6.  Рестартовать Caudium, если он в данный момент работает.
7.  Log в графический интерфейс конфигурации и перейдите в
    виртуальный сервер, где вы хотите добавить поддержку PHP 4.
8.  Щёлкните Add Module и найдите, а затем добавьте модуль PHP 4 Script Support.
9.  Если в документации говорится, что 'PHP 4 interpreter isn't
    available', убедитесь, что вы рестартовали сервер. Вы проверили
    /opt/caudium/logs/debug/default.1 на ошибки, относящиеся к
    <filename>PHP4.so</filename>? Также убедитесь, что
    <filename>caudium/server/lib/[pike-version]/PHP4.so</filename>
    существует.
10. Сконфигурируйте модель PHP Script Support, если необходимо.

Вы можете, конечно, скомпилировать ваш Caudium-модель с поддержкой различных расширений, имеющихся в PHP 4. См. в полном списке опций конфигурации исчерпывающую информацию.

Примечание: при компиляции PHP 4 с поддержкой MySQL вы обязаны убедиться, что используется нормальный клиентский код MySQL. Иначе могут быть конфликты, если ваш Pike уже имеет поддержку MySQL. Это делается путём специфицирования директории установки MySQL опцией --with-mysql.


НазадОглавление Вперёд
Серверы Apache Вверх Серверы fhttpd


Наш баннер
Вы можете установить наш баннер на своем сайте или блоге, скопировав этот код:
RSS новости