Справочное руководство по MySQL

4.3.9.2 Требования

    4.3.9.2 Требования

    Для того чтобы SSL-соединения могли работать с MySQL, необходимо выполнить следующие действия:

    1. Установите библиотеку OpenSSL. Тестирование MySQL производилось с библиотекой OpenSSL 0.9.6. http://www.openssl.org/.
    2. Выполните настройку компиляции MySQL (configure) при помощи параметров --with-vio --with-openssl.
    3. Если используется старая версия MySQL, то необходимо обновить таблицу mysql.user путем добавления в нее определенных новых столбцов. Это можно сделать, запустив скрипт mysql_fix_privilege_tables.sh.
    4. Проверить, скомпилирована ли в запущенном сервере mysqld библиотека OpenSSL можно, убедившись, что SHOW VARIABLES LIKE 'have_openssl' показывает YES.



Наш баннер
Вы можете установить наш баннер на своем сайте или блоге, скопировав этот код:
RSS новости