Справочное руководство по MySQL

2.6.6.2 Примечания к HP-UX версии 10.20

    2.6.6.2 Примечания к HP-UX версии 10.20

    При компиляции MySQL на HP-UX существует пара небольших проблем. Мы рекомендуем применять вместо собственного компилятора HP-UX gcc, потому что код, созданный gcc, лучше!

    Для HP-UX рекомендуется использование gcc 2.95. Не следует применять высокие уровни оптимизации (наподобие -O6), поскольку на HP-UX это может быть небезопасно.

    Заметим, что MIT-pthreads не могут быть скомпилированы компилятором HP-UX, поскольку он не компилирует ассемблерные файлы .S.

    Должна работать следующая строка конфигурации:

    CFLAGS="-DHPUX -I/opt/dce/include -fpic" \
    CXXFLAGS="-DHPUX -I/opt/dce/include -felide-constructors -fno-exceptions \
    -fno-rtti" CXX=gcc ./configure --with-pthread \
    --with-named-thread-libs='-ldce' --prefix=/usr/local/mysql
    --disable-shared
    

    Если вы компилируете gcc 2.95 самостоятельно, то для того, чтобы компилировать MySQL с MIT-pthreads, НЕ следует линковать его с DCE-библиотеками (libdce.a или libcma.a). Если смешать пакеты DCE и MIT-pthreads, то в результате получится mysqld, к которому нельзя подсоединиться. Удалите DCE-библиотеки во время компиляции gcc 2.95!




Наш баннер
Вы можете установить наш баннер на своем сайте или блоге, скопировав этот код:
RSS новости